Меню Закрыть

Программное создание дополнительных реквизитов в 1с 8.3

Введение.

Данная статья адресована разработчикам, а так же любопытным пользователям. Речь в ней пойдет о такой нужной функции конфигураций использующих БСП как дополнительные реквизиты.

Дополнительные реквизиты и сведения– механизм, позволяющий  не внося изменения в конфигурацию расширить её функциональность. Например, можно добавить дополнительные реквизит в документ Реализация товаров и услуг, для того, чтобы заполнять место погрузки или разгрузки в накладной. Причем сделать это нужно именно со стороны пользователя. Сейчас на смену этому механизму пришли расширения, однако пользователь самостоятельно сделать подобную настройку уже не сможет. Поэтому данный механизм еще актуален. Более того, расширения не работают в базовых версиях конфигураций, и тогда решать некоторые задачи приходится только с помощью дополнительных реквизитов.

Давайте теперь поговорим о таком важном моменте как создание дополнительного реквизита. Допустим, вы создали внешнюю печатную форму для документа Счет на оплату покупателю. И в ней в зависимости от значения некоторого параметра в справочнике Контрагенты будет включаться отображение некоторого столбца. Параметр этот, естественно, отсутствует в типовой конфигурации, однако мы знаем что есть замечательный механизм дополнительных реквизитов.  Теперь у нас появляется два варианта.

Вариант долгий и не оптимальный.

Нужно всего лишь попросить пользователя создать этот реквизит для справочника Контрагенты, написать длинную инструкцию, так как скорее всего пользователь никогда не слышал ни о дополнительных реквизитах, ни тем более о том как и где их создавать. Более того нужно еще быть уверенным, что пользователь нигде не ошибется в наименовании и типе создаваемого объекта.

Вариант незаметный для пользователя.

Сделать все эти действия можно программно и максимально освободить пользователя от лишних движений. В качестве примера попробуем создать дополнительный реквизит для справочника Контрагенты. Далее привожу текст процедуры, которая сделает все за нас. В тексте есть комментарии, так что разобраться не составит труда.

Процедуру можно вызвать при регистрации внешней формы
&НаСервере
Процедура СоздатьДопРеквизитНаСервере(ИмяРеквизита)
	
    //включим константу использования
    Если Не Константы.ИспользоватьДополнительныеРеквизитыИСведения.Получить() Тогда
        Константы.ИспользоватьДополнительныеРеквизитыИСведения.Установить(Истина);
    КонецЕсли;
	
	//попробуем найти реквизит по наименованию
	ДопРеквизитСсылка = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию(ИмяРеквизита);
	Если НЕ ЗначениеЗаполнено(ДопРеквизитСсылка) Тогда
		//если не нашли реквизит - будем его создавать
		ДопРеквизитОбъект = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.СоздатьЭлемент();
		ДопРеквизитОбъект.Заголовок = ИмяРеквизита;
		ДопРеквизитОбъект.НаборСвойств = Справочники.НаборыДополнительныхРеквизитовИСведений.Справочник_Контрагенты;
                ДопРеквизитОбъект.ТипЗначения = Новый ОписаниеТипов("Строка",,,,Новый КвалификаторыСтроки(250));
		ДопРеквизитОбъект.Наименование = ДопРеквизитОбъект.Заголовок + " ("+ДопРеквизитОбъект.НаборСвойств+")";
		ДопРеквизитОбъект.Виден = Истина;
		ДопРеквизитОбъект.Доступен = Истина;
		ДопРеквизитОбъект.ДополнительныеЗначенияИспользуются = Истина;
		//зададим имя нового реквизита
		ДопРеквизитОбъект.Имя = "filap_"+СтрЗаменить(ИмяРеквизита," ","");
		ДопРеквизитОбъект.Записать();
		ДопРеквизитСсылка = ДопРеквизитОбъект.Ссылка;		
	КонецЕсли;
	
    //добавим наш реквизит в набор дополнительных реквизитов контрагента
    НаборДополнительныхРеквизитовКонтрагента = Справочники.НаборыДополнительныхРеквизитовИСведений.Справочник_Контрагенты.ПолучитьОбъект();
    Если НаборДополнительныхРеквизитовКонтрагента.ДополнительныеРеквизиты.Найти(ДопРеквизитСсылка, "Свойство") = Неопределено Тогда
        //добавим реквизит в набор
        Стр = НаборДополнительныхРеквизитовКонтрагента.ДополнительныеРеквизиты.Добавить();
        Стр.Свойство = ДопРеквизитСсылка;
	НаборДополнительныхРеквизитовКонтрагента.Записать();
    КонецЕсли;
	
КонецПроцедуры

Также я создал простую обработку, с одной командой, которая при нажатии будет создавать реквизит с наименованием, которое можно ввести на форме обработки.

Форма обработки

Отметим, что необходимо обязательно сделать проверку на существование данного реквизита, так как пользователь мог повторно подключать нашу гипотетическую печатную форму. Так же не забудьте заполнить реквизит Имя – оно должно быть без пробелов. Это служебный реквизит, с помощью которого мы в дальнейшем сможем обращаться к значению нашего дополнительного реквизита. Если вы его не зададите – система сгенерирует его автоматически, но оно будет длинным и «некрасивым». Как несложно заметить, реквизит создался, и именно так как мы это описали в процедуре создания. Строковый тип длиной 250 символов.

Результат добавления

Ну и, наконец, убедимся, что реквизит отображается на форме справочника Контрагенты и его можно заполнять.

 

На этом все. Всем удачи!

Скачать обработку с примером Вы можете по этой ссылке.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *